为了适应wordpress最新的版本,本站模板已更新

e-mail发送工具

软路由 D A 1466℃

E-mail工具非常有用,允许从路由发送e-mail,这个工具被用于备份配置和导出网络管理信息,Email工具用于纯验证和TLS加密,其他模式不支持

属性

操作路径: /tool e-mail

这个子菜单下可以设置SMTP服务器

from (字符; 默认: <>)显示接收者的名称或者email地址。

password (字符; 默认: “”)SMTP服务器要求验证的密码

server (IP:Port; 默认: 0.0.0.0:25)SMTP服务器的IP地址和端口

username (字符; 默认: “”)SMTP服务器要求使用的用户名。

Email发送使用一些命令/tool e-mail send

发送命令采用下面参数:

body (字符; 默认: )邮件的实际信息

file (字符; 默认: ) Email的附件文件名称

from (字符; 默认: )名称或者email地址,.

password (字符; 默认: )密码用于SMTP服务的验证

server (IP:Port; 默认: ) IP地址和SMTP服务器端口

subject (字符; 默认: )邮件标题.

tls (yes|no; 默认: yes)是否使用TLS加密

to (字符; 默认: )目的emial地址

user (字符; 默认: )用于SMTP验证的用户名

基本事例

这个事例将说明如何导出配置,并每隔24小时发送email

1. 配置SMTP服务器

[admin@MikroTik] /tool e-mail> set server=10.1.1.1:25 from="router@mydomain.com"

2. 添加新的脚本,并取名称“export-send”

/export file=export
/tool e-mail send to="config@mydomain.com" subject="$[/system identity get name]  export) \
body="$[/system clock get date] configuration file" file=export.rsc

3.添加计划任务(scheduler),并设置运行export-send脚本

/system scheduler
add on-event="export-send" start-time=00:00:00 interval=24h

查看下面的接口列表:

[admin@MikroTik] interface> print
Flags: X - disabled, D - dynamic, R - running
 #    NAME                         TYPE             RX-RATE    TX-RATE    MTU
 0  R ether1                       ether            0          0          1500
 1  R bridge1                      bridge           0          0          1500
 2  R ether2                       ether            0          0          1500
 3  R wlan1                        wlan             0          0          1500
[admin@MikroTik] interface>

进入/interface bridge桥接配置,添加一个桥:

[admin@MikroTik] /interface bridge> add
[admin@MikroTik] /interface bridge> prin
Flags: X - disabled, R - running
 0  R name="bridge1" mtu=1500 arp=enabled mac-address=00:00:00:00:00:00
      protocol-mode=none priority=0x8000 auto-mac=yes
      admin-mac=00:00:00:00:00:00 max-message-age=20s forward-delay=15s
      transmit-hold-count=6 ageing-time=5m
[admin@MikroTik] /interface bridge>

E-mail在winbox下的操作路径:

E-mail发送工具

转载请注明:CentOS教程-网络技术总结 » e-mail发送工具

weixin_pay alipay_pay

本站的发展离不开您的资助,金额随意,欢迎来赏!

喜欢 (0)or分享 (0)