为了适应wordpress最新的版本,本站模板已更新

无线Nstreme配置ROS

软路由 D A 1308℃

Nstreme 点对点高带宽设置

Nstreme 是 RouterOS 独有的协议,支持数据帧重组,提高 WLAN 无线传输带宽,使用 Nstreme 特别依赖CPU性能,如果采用 RB433AH 在 5G-turbo 模式下可以获得70Mbps的带宽。注意:Nstreme 不支持 ap-bridge 对 ap-bridge 的模式

点我们可以采用 ap-bridge 或者 birdge 方式,在这里我们推荐使用 ap-bridge 与 station-wds 的桥接方式,如下图:

无线Nstreme配置

设置在ap-bridge和station-wds模式的我们分以下步骤:

  1. 在 ap-bridge 和 station-wds 中添加 bridge,定义 bridge 的接口,并分配管理的 IP 地址
  2. 配置 ap-bridge 和 station-wds 的无线参数
  3. 检查桥接连接情况

步骤1:进入bridge添加bridge1的桥接,通常情况下我会开启rstp协议,启用生成树协议:

无线Nstreme配置

添加 ether1 和 wlan1到 brdige1 桥接中,这里在 interface 中分别添加 ether1 和 wlan1 进入 bridge1 中。这样 ether1 和 wlan1 就实现了桥接功能,能实现数据二层的透明传输:

无线Nstreme配置

注:在RouterOS3.0的bridge中增加了一个设置选项,是否选择 ip firewall 过滤,如果不使用 ip firewall 过滤路由器的桥接转发速度将提升性能,但如果你要求对无线传输过程中的IP数据进行过滤处理,那就需要开启 use-ip-firewall 功能:

无线Nstreme配置

:以上配置操作适用于 ap-bridge 和 station-wds设备

设置完桥接后我们进入 ip address 给 ap-bridge 和 station-wds 的 bridge 配置一个IP地址 192.168.10.1/24 和 192.168.10.2/24,用于管理设备和监测用。这样 wlan1 口和 ether1 都能分配到这个地址。命令如下:

ap-bridge设备

/ip address add address=192.168.10.1/24 interface=bridge1

station-wds设备

/ip address add address=192.168.10.2/24 interface=bridge1

步骤2:桥接和IP地址设置好后,现在配置ap-bridge和station-wds的无线参数。

设置ap-bridge的无线,这里mode=ap-bridge,band=5G,frequency=5200,SSID=CDNAT

无线Nstreme配置

配置 ap-bridge 的 WDS 模式,配置参数 wds-mode=dynamic-mesh(动态方式),wds-default Bridge=bridge1(将连接无线添加到bridge中)

无线Nstreme配置

配置 station-wds 端的设置只需要将 Mode=station-wds band=5G,SSID=CDNAT,不需要设置 Frequency 参数,station-wds 在匹配 Band 和 SSID 后会自动搜索:

无线Nstreme配置

在 station-wds 模式下与 ap-bridge 的WDS参数配置相同

无线Nstreme配置

步骤3:当配置完成后,我们可以通过在 ap-brdige 端的设备查看是否连接,如果正常连接后 ap-bridge 端的 Wireless Tables 下会在 wlan1 前现时“R”,并增加一个 wds1 的无线接口。

无线Nstreme配置

在ap-bridge 下的 Bridge 中可以看到,WDS 模式自动将 wds1 接口添加到 Port 中:

无线Nstreme配置

我们可以通过在无线注册信息列表中查看信号强度:

无线Nstreme配置

这里显示的是-63,信号能连接使用的最低值在“-88到-90”,数字越接近正数“1”信号越强。Station-wds 端在连接后会自动适用 ap-bridge 的参数,并正常通信。

启用Nstreme协议

MikroTik 都有的 Nstreme 协议用于长距离的无线传输、增加带宽和提高网络质量的作用。 Nstreme 只支持 ap-bridge to station/station-wds,不支持 ap-bridge to ap-bridge,所以通常 Nstreme 被用于点对点传输或点对多点传输。启用 Nstreme 的操作只需要进入无线网卡配置的 Nstreme 选项。

在我们做点对点传输的时候,可以启用 Nsteme 协议,提高网络安全和传输质量。Ap-bridge 的配置,启用 Nsteme 协议,禁止 CSMA 协议,并选择最好的帧传输:

无线Nstreme配置

Station 和 station-wds 的配置,只需要启用即可:

无线Nstreme配置

Nstreme 协议必须双方同时启用,才能正常连接,所以配置 Nstreme 时一定要注意。

转载请注明:CentOS教程-网络技术总结 » 无线Nstreme配置ROS

weixin_pay alipay_pay

本站的发展离不开您的资助,金额随意,欢迎来赏!

喜欢 (0)or分享 (0)