多条ADSL(动态I和动态网关)ROS 的设置

多条ADSL(动态I和动态网关)ROS 的设置

 

 
[折叠]
第一个真正写 多个动态网关   设置的文章
请注意 与静态IP 和静态网关无关

如果你有2条以上的ADSL并且IP与网关都是动态的网关是静态的也可一按这种方法设置
—————————————————-1步

先把1网卡的名字改为adsl1(我的设置 要改为你起的名字)
先把2网卡的名字改为adsl2(我的设置 要改为你起的名字)
3条以上
先把3网卡的名字改为adsl3
先把4网卡的名字改为adsl4
……..
——————————————————-2步
添加路由表
表adsl1
表adsl2
3条以上 表adsl3 表adsl4
——————————————————-3步
然后 分别加网关   应为现在还不知道网关所以可以随便填
adsl1路由表 加网关 为1.1.1.1
adsl2路由表 加网关 为2.2.2.2
3条以上
adsl3路由表 加网关 为3.3.3.3
adsl4路由表 加网关 为4.4.4.4
——————————————————4步
路由规则里添加相应的规则和平时设置一样
关键是你的路由规则要按那张路由表走
——————————————————5步
添加PPOE 拨号
第一条拨号选网卡名为adsl1的网卡
第2条拨号选网卡名为adsl2的网卡
第3条拨号选网卡名为ads3的网卡
第3条拨号选网卡名为ads4的网卡

把 ADD DEFAULT ROUTE 前的对号去掉

注意一点 一定要先把ADD DEFAULT ROUTE 前的对号去掉
在点OK或应用 否则他会自动把ISP的网关天加到MAIN路由表里
你还要删除才行
——————————————————–6步
添加脚本adsl1
:global pppzt1
:global adslwg1
:global jackey1
/interface pppoe-client monitor pppoe-out1 once do={:set pppzt1 $status}
:if ($pppzt1=”connected”) do={
:set jackey1 [/ip address get [/ip address find interface=pppoe-out1] network]
:if ($jackey1!=$adslwg1) do={
:set adslwg1 $jackey1
/ip policy-routing table adsl1
set [/ip policy-routing table adsl1 find dst-address=0.0.0.0] gateway=$jackey1
}
}
添加脚本adsl2
:global pppzt2
:global adslwg2
:global jackey2
/interface pppoe-client monitor pppoe-out2 once do={:set pppzt2 $status}
:if ($pppzt2=”connected”) do={
:set jackey2 [/ip address get [/ip address find interface=pppoe-out2] network]
:if ($jackey2!=$adslwg2) do={
:set adslwg2 $jackey2
/ip policy-routing table adsl2
set [/ip policy-routing table adsl2 find dst-address=0.0.0.0] gateway=$jackey2
}
}

————–注意这两个脚本有一定区别 第3条 第4条 依次类推
意思是获取指定拨号成功后网卡上的网关
并把他加到你指定的陆游表里
—————————–7步
添加名为adsl1的 Schedule 脚本 目的是20秒执行一次adsl1脚本   interval=20秒     on event=adsl1

添加名为adsl2的 Schedule 脚本 目的是20秒执行一次ads2脚本   interval=20秒     on event=adsl2

依次类推
添加名为ads3的 Schedule 脚本 目的是20秒执行一次ads3脚本
添加名为ads4的 Schedule 脚本 目的是20秒执行一次ads4脚本

—-
6步和7步 总的意思是20秒把陆游表的网关换一次
附:

同网关多条ADSL线路分流实现
测试环境:南宁电信两条ADSL,ROS2.9.27破解版(routing-test包代替routing包,当然本实例和这两个包没关系)
1、正常两条AD拨号上来是这样的,有一条是不活动的,不能使用。

2、对PPPOE-OUT1和PPPOE-OUT2手动设置它们拨号所分配来的IP

3、在IP-ROUTE里把拨号得的网关172.0.0.1删掉(如果拨号时没钩选Add Default Route)这步不需要)

4、然后按拨号得的两个IP地址设置路由(先做好分流标志,这里是routing-mark=1和routing-mark=2)

5、设置NAT或masquerade就可以分流上网了。

第2步和第4步用脚本来控制就可以实现诸如AD掉线、切换等问题的解决了。论坛里的例子很多了,在此省略。